Vote Up 1 Vote Down

Could not initialize the application's security component firefox linux

I could not start firefox and got the following error:

Could not initialize the application's security component...

I tried restarting firefox but with no success. And also reinstaliing firefox doesn't solve the issue.

I am using firefox in ubuntu linux.
flag

Answers


Vote Up 1 Vote Down
Its because firefox having some permission issue.

Step 1:

Open the terminal and go to your home directory

cd /home


Step 2:

Open the terminal and search the file cert8.db in your home directory.

find -name cert.db


Step 3:

Several lines will be listed. Find the one that in the ./mozila directory ( The position may differ)

./.mozilla/firefox/5ropwcyq.default/cert8.db


Step 4:

Go to that dierctory

cd    ./.mozilla/firefox/5ropwcyq.default/


Step 5:

Check that it has read and write permissions if not give it:

sudo chmod 0777 cert.db


Step 6

Close the firefox browser and delete the file cert.db which is corrupted.

rm cert.db


Step 7:

Restart the browser it wil create new cert.db file and your firefox browser probably works fine.
flag | link |

Using Linux Mint, the name of my file was "cert8.db". Worked great, thanks!

on 9/8/13

Your Answer

Login before answering

Login with facebook