Vote Up 0 Vote Down

an error occurred application error exception information

Truly need your help

An error occurred

Application error
Exception information:
Message: No adapter found for ApplicationModelDbTable_User

Stack trace:

#0 C:\AppServ\php5\zend_framework\library\Zend\Db\Table\Abstract.php(739): Zend_Db_Table_Abstract->_setupDatabaseAdapter()
#1 C:\AppServ\php5\zend_framework\library\Zend\Db\Table\Abstract.php(268): Zend_Db_Table_Abstract->_setup()
#2 C:\AppServ\www\thenextsocial\application\models\UserMapper.php(9): Zend_Db_Table_Abstract->__construct()
#3 C:\AppServ\www\thenextsocial\application\controllers\IndexController.php(24): Application_Model_UserMapper->__construct()
#4 C:\AppServ\php5\zend_framework\library\Zend\Controller\Action.php(516): IndexController->indexAction()
#5 C:\AppServ\php5\zend_framework\library\Zend\Controller\Dispatcher\Standard.php(295): Zend_Controller_Action->dispatch('indexAction')
#6 C:\AppServ\php5\zend_framework\library\Zend\Controller\Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#7 C:\AppServ\php5\zend_framework\library\Zend\Application\Bootstrap\Bootstrap.php(97): Zend_Controller_Front->dispatch()
#8 C:\AppServ\php5\zend_framework\library\Zend\Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
#9 C:\AppServ\www\thenextsocial\public\index.php(26): Zend_Application->run()
#10 {main}


I am using zend framework. I am getting this error, what's happened here?
flag

Answers


Vote Up 0 Vote Down
If you're getting 'Application error' only, but no details, try changing the value of resources.frontController.params.displayExceptions in your application.ini from 0 to 1 to display error details.

I was then getting the error "No adapter found for Application_Model_DbTable_User". The problem is that under Step 1 above, the article is garbled. Within the code tags displaying the application.ini changes, there's an additional step which is easily missed, where you need to add a line to your .htaccess specifying what environment you're working in:
SetEnv APPLICATION_ENV development

Without that line, it's looking at the wrong section of the configuarion file, so not picking up the config details we just added. ..
flag | link |

Your Answer

Login before answering

Login with facebook